#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=XXX >>> \[|\G)([^][,]*),(?=[^][]*\])"
Local $sString = "ab, xy, de XXX >>> [a, b, c] foo, bar, baz"
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)