re = /(?<=XXX >>> \[|\G)([^][,]*),(?=[^][]*\])/
str = 'ab, xy, de XXX >>> [a, b, c] foo, bar, baz'
subst = '$1.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result