$re = '/(?<=XXX >>> \[|\G)([^][,]*),(?=[^][]*\])/';
$str = 'ab, xy, de XXX >>> [a, b, c] foo, bar, baz';
$subst = "$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;