using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=XXX >>> \[|\G)([^][,]*),(?=[^][]*\])";
string substitution = @"$1.";
string input = @"ab, xy, de XXX >>> [a, b, c] foo, bar, baz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}