$re = '/adm-list-table-cell.*<span class=\"del\".*\<\/td/';
$str = '<td class="adm-list-table-cell align-right"><a href="iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y" title="title">2</a></td><td class="adm-list-table-cell align-left adm-list-table-cell-last"> / / / / <span class="del">ALL</span> / / / / / / / / / / </td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);