import re
regex = re.compile(r"adm-list-table-cell.*<span class=\"del\".*\<\/td")
test_str = "<td class=\"adm-list-table-cell align-right\"><a href=\"iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y\" title=\"title\">2</a></td><td class=\"adm-list-table-cell align-left adm-list-table-cell-last\"> / / / / <span class=\"del\">ALL</span> / / / / / / / / / / </td>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")