// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"adm-list-table-cell.*<span class=\"del\".*\<\/td"#).unwrap();
let string = "<td class=\"adm-list-table-cell align-right\"><a href=\"iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y\" title=\"title\">2</a></td><td class=\"adm-list-table-cell align-left adm-list-table-cell-last\"> / / / / <span class=\"del\">ALL</span> / / / / / / / / / / </td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}