# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\.|\+.*)(?=.*?@gmail\.com)//g;t' <<< "n.fl.jersey.s@gmail.com
nfl.jerseys@gmail.com
n.flj.er.se.ys@gmail.com
foo+bar@gmail.com
"