import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\.|\\+.*)(?=.*?@gmail\\.com)";
final String string = "n.fl.jersey.s@gmail.com\n"
+ "nfl.jerseys@gmail.com\n"
+ "n.flj.er.se.ys@gmail.com\n"
+ "foo+bar@gmail.com\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}