import re
regex = re.compile(r"(?:\.|\+.*)(?=.*?@gmail\.com)")
test_str = ("n.fl.jersey.s@gmail.com\n"
"nfl.jerseys@gmail.com\n"
"n.flj.er.se.ys@gmail.com\n"
"foo+bar@gmail.com\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)