$re = '/(?:\.|\+.*)(?=.*?@gmail\.com)/';
$str = 'n.fl.jersey.s@gmail.com
nfl.jerseys@gmail.com
n.flj.er.se.ys@gmail.com
foo+bar@gmail.com
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;