using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<img.*?(?<!src=)src=(?P<quote>\""|\')(?P<src>img\/programacao\/[^\k<quote>]+)\k<quote>";
string input = @"""<img src=""img/programacao/51.jpg"" style=""width:200px;"" /><p>balbalba</p><img src=""img/programacao/46.jpg"" style=""width:200px;"" /><p>balbalba</p><img src=""/img/finalCinerio.jpg""><p>balbalba</p><img src=""img/topo.jpg"" />""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}