import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<img.*?(?<!src=)src=(?P<quote>\\\"|\\')(?P<src>img\\/programacao\\/[^\\k<quote>]+)\\k<quote>";
final String string = "\"<img src=\"img/programacao/51.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"img/programacao/46.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"/img/finalCinerio.jpg\"><p>balbalba</p><img src=\"img/topo.jpg\" />\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}