import re
regex = re.compile(r"\<img.*?(?<!src=)src=(?P<quote>\"|\')(?P<src>img\/programacao\/[^\k<quote>]+)\k<quote>")
test_str = ("\"<img src=\"img/programacao/51.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"img/programacao/46.jpg\" style=\"width:200px;\" /><p>balbalba</p><img src=\"/img/finalCinerio.jpg\"><p>balbalba</p><img src=\"img/topo.jpg\" />\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")