using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*)?\)\s*\{(.*)?\}\s*\;";
string input = @"env x='() { :;}; echo Your system is vulnerable' bash -c ""echo Test script""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}