re = /\((.*)?\)\s*\{(.*)?\}\s*\;/
str = 'env x=\'() { :;}; echo Your system is vulnerable\' bash -c "echo Test script"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end