package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((.*)?\)\s*\{(.*)?\}\s*\;`)
var str = `env x='() { :;}; echo Your system is vulnerable' bash -c "echo Test script"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}