$re = '/\((.*)?\)\s*\{(.*)?\}\s*\;/';
$str = 'env x=\'() { :;}; echo Your system is vulnerable\' bash -c "echo Test script"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);