import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\W_](?:[\\w.-]*[^\\W_])?@(?:\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.|(?:[\\w-]+\\.)+)(?:[a-zA-Z]{2,3}|[0-9]{1,3})\\]?$";
final String string = "abc@site.com\n"
+ ".abc@site.com\n"
+ "_abc@site.com\n"
+ "9abc@site.com\n"
+ "9abc.@site.com\n"
+ "a@site.com\n"
+ "!@site.com\n"
+ "a!@site.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}