re = /^[^\W_](?:[\w.-]*[^\W_])?@(?:\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.|(?:[\w-]+\.)+)(?:[a-zA-Z]{2,3}|[0-9]{1,3})\]?$/m
str = 'abc@site.com
.abc@site.com
_abc@site.com
9abc@site.com
9abc.@site.com
a@site.com
!@site.com
a!@site.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end