const regex = /^[^\W_](?:[\w.-]*[^\W_])?@(?:\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.|(?:[\w-]+\.)+)(?:[a-zA-Z]{2,3}|[0-9]{1,3})\]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\W_](?:[\\w.-]*[^\\W_])?@(?:\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.|(?:[\\w-]+\\.)+)(?:[a-zA-Z]{2,3}|[0-9]{1,3})\\]?$', 'gm')
const str = `abc@site.com
.abc@site.com
_abc@site.com
9abc@site.com
9abc.@site.com
a@site.com
!@site.com
a!@site.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}