#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*?source\s+(.*)"
Local $sString = "source ./file/path/here.sh" & @CRLF & _
                " source /filepath" & @CRLF & _
                "  source ~/filepath/.git/do.pl" & @CRLF & _
                "       source      ~/filepath/.git/do.pl sdfsdf" & @CRLF & _
                "       source      ~/filepath/.git/do.pl\ sdfsdf" & @CRLF & _
                "" & @CRLF & _
                ""not source ,.ss""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")