const regex = /^\s*?source\s+(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*?source\\s+(.*)', 'gm')
const str = `source ./file/path/here.sh
source /filepath
source ~/filepath/.git/do.pl
source ~/filepath/.git/do.pl sdfsdf
source ~/filepath/.git/do.pl\\ sdfsdf
"not source ,.ss"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}