$re = '/^\s*?source\s+(.*)/m';
$str = 'source ./file/path/here.sh
source /filepath
source ~/filepath/.git/do.pl
source ~/filepath/.git/do.pl sdfsdf
source ~/filepath/.git/do.pl\\ sdfsdf
"not source ,.ss"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);