// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*?source\s+(.*)").unwrap();
let string = "source ./file/path/here.sh
source /filepath
source ~/filepath/.git/do.pl
source ~/filepath/.git/do.pl sdfsdf
source ~/filepath/.git/do.pl\\ sdfsdf
\"not source ,.ss\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}