# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z0-9])([A-Z0-9]{3})([A-Z0-9]{4})([A-Z0-9]{2})([A-Z0-9]{3})([A-Z0-9])/$1-$2 $3 $4-$5 ($6)/g;t' <<< "X839WS21R4E877
X83RWS21B3E87A
"