// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z0-9])([A-Z0-9]{3})([A-Z0-9]{4})([A-Z0-9]{2})([A-Z0-9]{3})([A-Z0-9])").unwrap();
let string = "X839WS21R4E877
X83RWS21B3E87A
";
let substitution = "$1-$2 $3 $4-$5 ($6)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}