import Foundation
let pattern = #"([A-Z0-9])([A-Z0-9]{3})([A-Z0-9]{4})([A-Z0-9]{2})([A-Z0-9]{3})([A-Z0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
X839WS21R4E877
X83RWS21B3E87A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2 $3 $4-$5 ($6)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)