$re = '/([A-Z0-9])([A-Z0-9]{3})([A-Z0-9]{4})([A-Z0-9]{2})([A-Z0-9]{3})([A-Z0-9])/';
$str = 'X839WS21R4E877
X83RWS21B3E87A
';
$subst = "$1-$2 $3 $4-$5 ($6)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;