#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\b(dv|dovi|dolby[ .]?vision|hdr(10(P(lus)?)?)?)\b"
Local $sString = "# MATCH" & @CRLF & _
"Series S01 1080p NF WEB-DL DDP 5.1 DoVi HDR HEVC-RlsGrp" & @CRLF & _
"Series S01 1080p NF WEB-DL DDP 5.1 HDR DoVi HEVC-RlsGrp" & @CRLF & _
"Series.S01.DV.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.DoVi.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.Dolby.Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.Dolby Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.HDR.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.HDR10.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.HDR10+.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series.S01.HDR10Plus.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"Series S01E03 2160p AMZN WEB-DL DDPA5 1 HDR10P HEVC-RlsGrp" & @CRLF & _
"" & @CRLF & _
"# DON'T MATCH" & @CRLF & _
"Series.S03.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp" & @CRLF & _
"adventure" & @CRLF & _
"hdruin" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")