$re = '/\b(dv|dovi|dolby[ .]?vision|hdr(10(P(lus)?)?)?)\b/im';
$str = '# MATCH
Series S01 1080p NF WEB-DL DDP 5.1 DoVi HDR HEVC-RlsGrp
Series S01 1080p NF WEB-DL DDP 5.1 HDR DoVi HEVC-RlsGrp
Series.S01.DV.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.DoVi.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.Dolby.Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.Dolby Vision.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10+.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series.S01.HDR10Plus.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
Series S01E03 2160p AMZN WEB-DL DDPA5 1 HDR10P HEVC-RlsGrp
# DON\'T MATCH
Series.S03.1080p.NF.WEB-DL.DDPA5.1.H.265-RlsGrp
adventure
hdruin
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);