using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[^\s]+\b)";
string substitution = @"";
string input = @"38/46 MAG/+2Z";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}