use strict;
my $str = '38/46 MAG/+2Z';
my $regex = qr/(\b[^\s]+\b)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";