using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.+src=[\'""](?P<src>.+?)[\'""].*>";
string input = @"<img style=""max-width:100%"" src=""http://media.doisongphapluat.com/thumb_x670x/2015/12/26/thumon.png"" alt="">";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}