const regex = /<img.+src=[\'"](?P<src>.+?)[\'"].*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.+src=[\\\'"](?P<src>.+?)[\\\'"].*>', 'i')
const str = `<img style="max-width:100%" src="http://media.doisongphapluat.com/thumb_x670x/2015/12/26/thumon.png" alt="">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}