re = /<img.+src=[\'"](?P<src>.+?)[\'"].*>/i
str = '<img style="max-width:100%" src="http://media.doisongphapluat.com/thumb_x670x/2015/12/26/thumon.png" alt="">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end