#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d[A-Z]{2}\d-[A-Z]{2}\d-[A-Z]{2}\d{2}\b"
Local $sString = "1EG4-TE5-MK73" & @CRLF & _
"SSG4-TE5-MK73" & @CRLF & _
"2EX4-GH5-KJ66" & @CRLF & _
"2EX4-GH5-KJ662"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")