$re = '/\b\d[A-Z]{2}\d-[A-Z]{2}\d-[A-Z]{2}\d{2}\b/m';
$str = '1EG4-TE5-MK73
SSG4-TE5-MK73
2EX4-GH5-KJ66
2EX4-GH5-KJ662';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);