using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d[A-Z]{2}\d-[A-Z]{2}\d-[A-Z]{2}\d{2}\b";
string input = @"1EG4-TE5-MK73
SSG4-TE5-MK73
2EX4-GH5-KJ66
2EX4-GH5-KJ662";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}