import re
regex = re.compile(r"\b\d[A-Z]{2}\d-[A-Z]{2}\d-[A-Z]{2}\d{2}\b", flags=re.MULTILINE)
test_str = ("1EG4-TE5-MK73\n"
"SSG4-TE5-MK73\n"
"2EX4-GH5-KJ66\n"
"2EX4-GH5-KJ662")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")