#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+|-\d+|-?\d{1,2}%|-?100%|(-?\d+<(-?\d{1,2}%|-?100%|-?\d+) )*(-?\d+<(-?\d{1,2}%|-?100%|-?\d+)))$"
Local $sString = "100%" & @CRLF & _
"1" & @CRLF & _
"-2" & @CRLF & _
"1<2 -2<50%" & @CRLF & _
"2<100%" & @CRLF & _
"-80%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")