$re = '/^(\d+|-\d+|-?\d{1,2}%|-?100%|(-?\d+<(-?\d{1,2}%|-?100%|-?\d+) )*(-?\d+<(-?\d{1,2}%|-?100%|-?\d+)))$/m';
$str = '100%
1
-2
1<2 -2<50%
2<100%
-80%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);