re = /^(\d+|-\d+|-?\d{1,2}%|-?100%|(-?\d+<(-?\d{1,2}%|-?100%|-?\d+) )*(-?\d+<(-?\d{1,2}%|-?100%|-?\d+)))$/m
str = '100%
1
-2
1<2 -2<50%
2<100%
-80%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end