package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+|-\d+|-?\d{1,2}%|-?100%|(-?\d+<(-?\d{1,2}%|-?100%|-?\d+) )*(-?\d+<(-?\d{1,2}%|-?100%|-?\d+)))$`)
var str = `100%
1
-2
1<2 -2<50%
2<100%
-80%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}