#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\b(CB\d+)(.+?)\b(Bus\d+)"
Local $sString = " \fCalibri|b1|i0|c00|p39;CB537" & @CRLF & _
" 73" & @CRLF & _
" 2" & @CRLF & _
" 44" & @CRLF & _
" 1.0" & @CRLF & _
" 1001" & @CRLF & _
" ACAD" & @CRLF & _
" 1000" & @CRLF & _
" MTEXTBEGIN" & @CRLF & _
" 1070" & @CRLF & _
"" & @CRLF & _
" 1611.0" & @CRLF & _
" 30" & @CRLF & _
" 0.0" & @CRLF & _
" 40" & @CRLF & _
" 1.302083" & @CRLF & _
" 41" & @CRLF & _
" 0.0" & @CRLF & _
" 71" & @CRLF & _
" 1" & @CRLF & _
" 72" & @CRLF & _
" 1" & @CRLF & _
" 1" & @CRLF & _
" \fCalibri|b1|i0|c00|p39;Line155" & @CRLF & _
" //trim" & @CRLF & _
" 72" & @CRLF & _
" 1" & @CRLF & _
" 1" & @CRLF & _
" \fCalibri|b0|i0|c00|p39;120" & @CRLF & _
"" & @CRLF & _
" \fCalibri|b1|i0|c00|p39;Bus459"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")