# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(CB\d+)(.+?)\b(Bus\d+)"
test_str = (" \\fCalibri|b1|i0|c00|p39;CB537\n"
" 73\n"
" 2\n"
" 44\n"
" 1.0\n"
" 1001\n"
" ACAD\n"
" 1000\n"
" MTEXTBEGIN\n"
" 1070\n\n"
" 1611.0\n"
" 30\n"
" 0.0\n"
" 40\n"
" 1.302083\n"
" 41\n"
" 0.0\n"
" 71\n"
" 1\n"
" 72\n"
" 1\n"
" 1\n"
" \\fCalibri|b1|i0|c00|p39;Line155\n"
" //trim\n"
" 72\n"
" 1\n"
" 1\n"
" \\fCalibri|b0|i0|c00|p39;120\n\n"
" \\fCalibri|b1|i0|c00|p39;Bus459")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.