re = /\b(CB\d+)(.+?)\b(Bus\d+)/m
str = ' \\fCalibri|b1|i0|c00|p39;CB537
73
2
44
1.0
1001
ACAD
1000
MTEXTBEGIN
1070
1611.0
30
0.0
40
1.302083
41
0.0
71
1
72
1
1
\\fCalibri|b1|i0|c00|p39;Line155
//trim
72
1
1
\\fCalibri|b0|i0|c00|p39;120
\\fCalibri|b1|i0|c00|p39;Bus459'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end