use strict;
my $str = ' \\fCalibri|b1|i0|c00|p39;CB537
73
2
44
1.0
1001
ACAD
1000
MTEXTBEGIN
1070
1611.0
30
0.0
40
1.302083
41
0.0
71
1
72
1
1
\\fCalibri|b1|i0|c00|p39;Line155
//trim
72
1
1
\\fCalibri|b0|i0|c00|p39;120
\\fCalibri|b1|i0|c00|p39;Bus459';
my $regex = qr/\b(CB\d+)(.+?)\b(Bus\d+)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}