$re = '/(?P<dd>\d{1,2})(?P<sep>[\/.-]{1})(?P<mm>\d{1,2})(?P=sep)(?P<yy>\d{2,4})/i';
$str = 'data: 12/11/2011
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);