// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?P<dd>\d{1,2})(?P<sep>[\/.-]{1})(?P<mm>\d{1,2})(?P=sep)(?P<yy>\d{2,4})").unwrap();
let string = "data: 12/11/2011
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}